Archicad 28 C++ API
Loading...
Searching...
No Matches
API_GetParamsType Struct Reference

The changed parameter values of a Library Part. More...

#include <APIdefs_Goodies.h>

Public Attributes

double a
 value of the 'A' parameter
 
double b
 value of the 'B' parameter
 
API_AddParType ** params
 Additional parameters from the library part.
 

Detailed Description

The changed parameter values of a Library Part.

Remarks
This structure is used to get the actual parameters set by the ACAPI_LibraryPart_ChangeAParameter function. Remember to dispose the params handle when it is not needed anymore. Refer to the ACAPI_DisposeAddParHdl to do that.