Archicad 28 C++ API
Loading...
Searching...
No Matches
API_IFCTranslatorIdentifier Struct Reference

IFC Translator Identifier. More...

#include <APIdefs_Automate.h>

Public Member Functions

 API_IFCTranslatorIdentifier (const API_IFCTranslatorIdentifier &that)
 Copy constructor.
 
 API_IFCTranslatorIdentifier (API_IFCTranslatorIdentifier &&that)
 Move constructor.
 
API_IFCTranslatorIdentifieroperator= (API_IFCTranslatorIdentifier other)
 Assignment operator.
 
void Swap (API_IFCTranslatorIdentifier &other)
 Swap the object with the parameter.
 

Public Attributes

GSHandle innerReference
 Internal reference.
 
GS::UniString name
 IFC Translator name.
 

Friends

void Swap (API_IFCTranslatorIdentifier &left, API_IFCTranslatorIdentifier &right)
 Swap the first and second parameters.
 

Detailed Description

IFC Translator Identifier.

Since
Archicad 26
Remarks
This structure is used in ACAPI_IFC_GetIFCExportTranslatorsList.

Constructor & Destructor Documentation

◆ API_IFCTranslatorIdentifier() [1/2]

API_IFCTranslatorIdentifier::API_IFCTranslatorIdentifier ( const API_IFCTranslatorIdentifier that)
inline

Copy constructor.

Parameters
thatThe other API_IFCTranslatorIdentifier object.

◆ API_IFCTranslatorIdentifier() [2/2]

API_IFCTranslatorIdentifier::API_IFCTranslatorIdentifier ( API_IFCTranslatorIdentifier &&  that)
inline

Move constructor.

Parameters
thatThe other API_IFCTranslatorIdentifier object.

Member Function Documentation

◆ operator=()

API_IFCTranslatorIdentifier & API_IFCTranslatorIdentifier::operator= ( API_IFCTranslatorIdentifier  other)
inline

Assignment operator.

Parameters
otherAnother object to use as the source.
Returns
Returns with *this.

◆ Swap()

void API_IFCTranslatorIdentifier::Swap ( API_IFCTranslatorIdentifier other)
inline

Swap the object with the parameter.

Parameters
otherThe parameter to be swapped.

Friends And Related Symbol Documentation

◆ Swap

void Swap ( API_IFCTranslatorIdentifier left,
API_IFCTranslatorIdentifier right 
)
friend

Swap the first and second parameters.

Parameters
leftThe first parameter to be swapped.
rightThe second parameter to be swapped.