Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LayoutBook Struct Reference

Represents the Book settings. More...

#include <APIdefs_Database.h>

Public Attributes

bool flatNumbering
 Use flat Layout order or hierarchy (Tree view by Subset).
 
GS::UniString prefix
 ID Prefix.
 
API_NumberingStyle numberingStyle
 ID appearance style.
 
Int32 startAt
 Start numbering at.
 
bool useChangeOwnID
 Use change ID or Number by Revisions.
 
GS::UniString changePrefix
 ID prefix in Revisions.
 
API_NumberingStyle changeNumberingStyle
 ID appearance style in Revisions.
 
GS::HashTable< API_Guid, GS::UniString > customScheme
 Contains the custom data fields. The custom scheme GUID-value pairs are stored in a GS::HashTable.
 

Detailed Description

Represents the Book settings.

Remarks
You can get Book Settings via ACAPI_Navigator_GetLayoutBook function.