Archicad 28 C++ API
Loading...
Searching...
No Matches
API_LengthDimFormat Struct Reference

The representation of the linear, radial, level, elevation, door/window and parapet dimensioning on the Preferences / Dimensioning tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_LengthTypeID unit
 measurement unit, for the possible values see API_LengthTypeID
 
short roundInch
 fractional inches (1, 2, 4, 8, 16, 32, 64)
 
short lenDecimals
 number of decimals (0, 1, 2, 3, 4)
 
bool show0Whole
 show zeros to the left of the decimal point
 
char show0Inch
 show zeros to the left of the decimal inches
 
API_ExtraAccuracyID showSmall5
 European methods for rounding decimal values.
 
bool hide0Dec
 hide zeros at the right of the decimal point
 

Detailed Description

The representation of the linear, radial, level, elevation, door/window and parapet dimensioning on the Preferences / Dimensioning tab page.

Remarks
This structure is a member of API_DimensionPrefs.