Archicad 28 C++ API
Loading...
Searching...
No Matches
API_DimensionPrefs Struct Reference

The representation of the Project Preferences / Dimensions tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_LengthDimFormat linear
 Linear Dimensions preferences.
 
API_AngleDimFormat angle
 Angular Dimensions preferences.
 
API_LengthDimFormat radial
 Radial Dimensions preferences.
 
API_LengthDimFormat level
 Level Dimensions preferences.
 
API_LengthDimFormat elevation
 Elevation Dimensions preferences.
 
API_LengthDimFormat doorwindow
 Door, Window and Skylight Dimensions preferences.
 
API_LengthDimFormat parapet
 Sill Height Dimensions preferences.
 
API_AreaDimFormat area
 Area Calculations preferences.
 
short index
 dimension style attribute index if the dimension preferences are stored for views (see API_DimensionStandardsType)
 

Detailed Description

The representation of the Project Preferences / Dimensions tab page.

See also
ACAPI_ProjectSetting_GetPreferences, ACAPI_ProjectSetting_SetPreferences
Remarks
This structure is used by the ACAPI_ProjectSetting_GetPreferences function to get the settings of the Project Preferences / Dimensions page.