Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AreaDimFormat Struct Reference

The representation of the area dimensioning on the Preferences / Dimensioning tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_AreaTypeID unit
 measurement unit, for the possible values see API_AreaTypeID
 
short lenDecimals
 number of decimals (0, 1, 2, 3, 4)
 
bool hide0Dec
 hide zeros at the right of the decimal point
 

Detailed Description

The representation of the area dimensioning on the Preferences / Dimensioning tab page.

Remarks
This structure is a member of API_DimensionPrefs.