Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AngleDimFormat Struct Reference

The representation of the angle dimensioning on the Preferences / Dimensioning tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

API_AngleTypeID unit
 measurement unit, for the possible values see API_AngleTypeID
 
short angleDecimals
 number of digits when using decimal degrees, grad or radian units (0, 1, 2, 3, 4)
 
short angleAccuracy
 precision of the angle measurement units (°, ', ")
 
bool hide0Dec
 hide zeros at the right of the decimal point
 

Detailed Description

The representation of the angle dimensioning on the Preferences / Dimensioning tab page.

Remarks
This structure is a member of API_DimensionPrefs.