Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ListData_Head Struct Reference

Contains common information related to all listing component types. More...

#include <APIdefs_ListData.h>

Public Attributes

API_ListDataID typeID
 type of the listdata
 
Int32 setIndex
 index of the list data set the component is in
 
Int32 index
 index of the listdata in the set
 

Detailed Description

Contains common information related to all listing component types.

Remarks
This structure contains general information about a listdata. Below you can find the types of the list data:
Value Meaning
API_ZombieListDataID A dummy value (0).
API_KeyID Denotes a key listdata.
API_UnitID Denotes an unit listdata.
API_Obsolete_ComponentID Denotes a component listdata.
API_DescriptorID Denotes a descriptor listdata.
ACAPI_OldListing_Get, ACAPI_OldListing_GetLocal, ACAPI_OldListing_Search