Archicad 28 C++ API
Loading...
Searching...
No Matches
API_MDCLParameter Struct Reference

Parameter structure used for inter-addon communication. More...

#include <APIdefs_Goodies.h>

Public Attributes

Int32 index
 Parameter index (used only with ACAPI_AddOnAddOnCommunication_GetMDCLParameter)
 
const char * name
 Pointer to the name of the parameter.
 
Int32 type
 Type of the parameter. Can be one of the following constants:
 
bool modified
 The parameter was modified with the ACAPI_AddOnAddOnCommunication_ChangeMDCLParameter function.
 
union { 
 
   Int32   int_par 
 Integer or pointer parameter value (valid only if type is MDCLPar_int)
 
   void *   ptr_par 
 Pointer parameter value (valid only if type is MDCLPar_pointer). Note that on 64-bit the size of pointers is 8 bytes.
 
};  
 
double float_par
 Floating point parameter value (valid only if type is MDCLPar_float).
 
const char * string_par
 String parameter value (valid only if type is MDCLPar_string).
 

Detailed Description

Parameter structure used for inter-addon communication.

Remarks
This structure is used for parameter passing in inter-addon communications. For further information refer to the Communication Manager.

Member Data Documentation

◆ type

API_MDCLParameter::type

Type of the parameter. Can be one of the following constants:

Parameter type Meaning
MDCLPar_string string type parameter
MDCLPar_int integer type parameter
MDCLPar_float floating point number type parameter
MDCLPar_pointer pointer type parameter