Archicad 28 C++ API
Loading...
Searching...
No Matches
API_MagicWandInfo Struct Reference

Curve tracing parameters. More...

#include <APIdefs_Environment.h>

Public Attributes

short divArcMode
 Mode of the approximating curves with linear segments. Possible values are:
 
short traceMethod
 Trace method mode. Possible values are:
 
short arcSegNumb
 The deviation from curves less than.
 
double arcDiff
 Number of the segment along arc/circles.
 
double partLength
 Segment length.
 

Detailed Description

Curve tracing parameters.

Remarks
This structure corresponds to the "Magic Wand Settings..." dialog of Archicad. Follow the actual settings in the case yo need to trace curves with linear segments. Refer to the ACAPI_UserInput_GetMagicWandSets function to get the current settings.