Archicad 28 C++ API
Loading...
Searching...
No Matches
API_MarkUpType Struct Reference

Represents a Mark-Up entry. More...

#include <APIdefs_Elements.h>

Public Member Functions

 API_MarkUpType (GS::UniString name=GS::UniString(), API_Guid parentGuid=APINULLGuid)
 Constructor.
 

Public Attributes

API_Guid guid
 Identifier of the Mark-Up.
 
GS::UniString name
 Name.
 
API_Guid parentGuid
 The identifier of the parent Mark-Up.
 
GSTime creaTime
 Creation time.
 
GSTime modiTime
 Modification time.
 
GS::UniString tagText
 Tag text.
 
API_Guid tagTextElemGuid
 The identifier of the attached tag text element.
 
bool isTagTextElemVisible
 The visibility of the attached tag text element.
 

Detailed Description

Represents a Mark-Up entry.

Remarks
Use ACAPI_Markup_Create function to create and ACAPI_Markup_Delete function to delete Mark-Up entry. Mark-Ups can be listed with ACAPI_Markup_GetList function. Elements can be attached to the Mark-Up using ACAPI_Markup_AttachElements and comment can be added with ACAPI_Markup_AddComment function.

Constructor & Destructor Documentation

◆ API_MarkUpType()

API_MarkUpType::API_MarkUpType ( GS::UniString  name = GS::UniString (),
API_Guid  parentGuid = APINULLGuid 
)
inline

Constructor.

Parameters
nameName of the Mark-Up.
parentGuidThe identifier of the parent Mark-Up.