Archicad 27 C++ API
Loading...
Searching...
No Matches
API_MeshLevel Struct Reference

Defines the level lines of a mesh. More...

#include <APIdefs_Elements.h>

Public Attributes

Int32 nCoords
 Number of vertices in the level lines.
 
Int32 nSubLines
 Number of sublines including the first one.
 

Detailed Description

Defines the level lines of a mesh.

Remarks
This structure should be used in conjunction with the meshLevelCoords and meshLevelEnds fields of API_ElementMemo. The meshLevelCoords field defines the coordinates of the level line points; while meshLevelEnds field contains the indices of the end points of each level line in the meshLevelCoords array.