Archicad 28 C++ API
|
Structure for picture conversion using MIME identifier. More...
#include <APIdefs_Goodies.h>
Public Attributes | |
const char * | mimeIn |
MIME type of the image to be converted (e.g. "image/png", null-terminated C string) | |
GSHandle | inputHdl |
contains the input image handle | |
const char * | mimeOut |
the requested MIME type of the output image (e.g. "image/jpeg", null-terminated C string) | |
GSHandle | outputHdl |
on return contains the output image | |
bool | inContainsMime |
for library part preview pictures, where the input handle (inputHdl ) starts with a MIME type | |
API_ColorDepthID | outDepth |
the requested output pixel depth (APIColorDepth_FromSourceImage ) means to use the same pixel depth the input image has) | |
Structure for picture conversion using MIME identifier.
mimeOut
field: "vnd/DIB" results in outputHdl
containing a device independent bitmap. In some cases the image handle contains the MIME type as well. For example pictures in Library Parts are stored in a handle that begins with the '\0'-terminated MIME type string, and then follows the image itself. If inputHdl is in this format, set the inContainsMime
field to true
. In this case the mimeIn
parameter is ignored.