Archicad 28 C++ API
Loading...
Searching...
No Matches
API_MiscPrinterInfo Struct Reference

Miscellaneous information of the selected printer. More...

#include <APIdefs_Environment.h>

Public Attributes

char name [256]
 Name of the selected printer.
 
bool orientPortrait
 Currently selected orientation: portrait (true) or landscape (false).
 
char filler [7]
 Reserved for later use.
 

Detailed Description

Miscellaneous information of the selected printer.

Remarks
This structure contains name and orientation of selected printer in Archicad. Call the ACAPI_ProjectOperation_GetMiscPrinterInfo function to get this data.