Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ModulData Struct Reference

Control information of a custom data section saved into the project file. More...

#include <APIdefs_ModulData.h>

Public Attributes

Int32 dataVersion
 Data version; use this for backward compatibility.
 
unsigned short platformSign
 Byte ordering in data storage (can be either GS::Win_Platform_Sign, GS::Mac_Platform_Sign or GS::Mactel_Platform_Sign.
 
GSHandle dataHdl
 User specified data (cannot be nullptr).
 

Detailed Description

Control information of a custom data section saved into the project file.

Remarks
This structure is used by the ModulData Manager functions, for further details refer to these sections.