Archicad 28 C++ API
|
Parameters of a project Navigator Set. More...
#include <APIdefs_Navigator.h>
Public Attributes | |
char | name [128] |
The name of navigator set. | |
API_Guid | guid |
The own GUID of the navigator set. | |
API_Guid | rootGuid |
The GUID of the root. | |
API_NavigatorMapID | mapId |
The navigator set belongs to this map. | |
bool | wantsExtraInfo |
Indicates that you need the publishing information (host/ dirname/ path ) for the set. | |
GS::UniString * | host |
Contains the host name for internet publishing. | |
GS::UniString * | dirName |
Contains the directory name for internet publishing. | |
IO::Location * | path |
Contains the full output path for local/LAN publishing. | |
Int32 | filler [3] |
Reserved for later use. | |
IO::Location * | twFileServerPath |
Output path on OpenBIMcloud (only when publishing to OpenBIMcloud, otherwise nullptr). | |
Parameters of a project Navigator Set.