Archicad 28 C++ API
|
Defines the parameters of the Object Settings dialog. More...
#include <APIdefs_Interface.h>
Public Attributes | |
API_Element | elemDef |
[in/out] the default symbol on input; the selected symbol on output | |
API_Element | elemMask |
[in] defines which fields of elemDef should be used only | |
API_AddParType ** | addPars |
[out] additional symbol parameters | |
char | subtypeID [128] |
[out] The GUID of the object's subtype. | |
Int32 | propIndivLibInd |
[out] library index of individually assigned property object to be linked to the element ( 0 value means no property assigned individually) | |
bool | propCriteria |
[out] matching properties by criteria need to be linked to the element | |
Defines the parameters of the Object Settings dialog.