Representation of the display only options.
More...
#include <APIdefs_ViewSettings.hpp>
|
char | wallMode |
| The wall and beam intersection display method. (API_Drawing_Clean , API_Drawing_Constr )
|
|
bool | showRoofPivLine |
| Specifies whether roof pivot lines are displayed.
|
|
bool | showFillHandles |
| Specifies whether Fill handles are displayed.
|
|
char | lineWeight |
| Specifies whether lines are displayed with their true weight. (API_LWeight_On , API_LWeight_Hairline )
|
|
char | textMode |
| Specifies whether Text block handles are displayed. (API_TextSet_Normal , API_TextSet_Handles )
|
|
char | figureMode |
| Specifies whether Figure handles are displayed. (API_Figure_WithHandles , API_Figure_WithoutHandles )
|
|
bool | showExtrudedBodies |
| Specifies to show cut bodies for shell and roof in 3D (OpenGL only).
|
|
char | camPathViewMode |
| Specifies camera path visibility (Archicad only): API_CamPath_None , API_CamPath_CamerasOnly , API_CamPath_CamerasAndPath , API_CamPath_Everything
|
|
char | wallMethod |
| Specifies the beam drawing style (Archicad only): API_Wall_Drawing_Contour , API_Wall_Drawing_RefLine
|
|
bool | showMarkerRange |
| Specifies if the range of different markers is visible.
|
|
char | filldrawingMode |
| Specifies the how vector fills are displayed: API_Fill_Vector , API_Fill_Bitmap
|
|
bool | splineMode |
| Specifies whether spline handles are visible.
|
|
bool | showDrawingFrames |
| Specifies whether drawing frames are visible.
|
|
bool | showMasterItems |
| Specifies whether master layout items are visible on layouts.
|
|
bool | boldCutLines |
| Specifies whether cut lines are displayed as bold.
|
|
bool | showSourceMarkerBound |
| Specifies if the bounds of markers are visible.
|
|
bool | showDimensionAllLines |
| Specifies if dimensions' reference lines should be visible.
|
|
bool | showOpeningCuttingBodies |
| Specifies if openings' cutting bodies should be visible.
|
|
bool | showOpeningReferences |
| Specifies if openings' reference lines should be visible.
|
|
Representation of the display only options.