Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ParamOwnerType Struct Reference

Parameters to specify the target parameter list to change. More...

#include <APIdefs_Goodies.h>

Public Attributes

API_Guid guid
 element unique ID
 
Int32 libInd
 library part index
 
API_ElemType type
 element type
 

Detailed Description

Parameters to specify the target parameter list to change.

Since
Archicad 26
Remarks
This structure is used to specify the target of which the parameter list should be opened to edit. Possible targets are:
  • default parameters of a Library Part itself
  • default parameters of an element (default tool settings)
  • parameters of a placed element (Library Part instance)

The required parameters for library part default:

API_ParamOwnerType
guid ignored
libInd required; set to the Library Part index
type ignored

The required parameters for element default:

API_ParamOwnerType
guid required; set to APINULLGuid
libInd required; set to zero
type required

The required parameters for a placed element:

API_ParamOwnerType
guid required; set to the element's unique ID
libInd required; set to zero
type required