Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PenTableType Struct Reference

Pen table attribute. More...

#include <APIdefs_Attributes.h>

Public Attributes

API_Attr_Head head
 Contains the name, guid and the index of the attribute.
 
bool inEffectForModel
 This is the active pen table for the model space.
 
bool inEffectForLayout
 This is the active pen table for the layout.
 

Detailed Description

Pen table attribute.

Remarks
Pen tables are new in Archicad 10, introduced because of the layouting functionality. Each pen table contains 255 pens. Separate pen tables can be active for the layouting and for the model windows. The pens of the pentable are passed in the penTable_Items field of the API_AttributeDefExt structure.