Archicad 27 C++ API
Loading...
Searching...
No Matches
API_PolyArc Struct Reference

Representation of an arc segment of a two dimensional polygon. More...

#include <APIdefs_Base.h>

Public Attributes

Int32 begIndex
 Node index of one end point of the arc.
 
Int32 endIndex
 Node index of the other end point of the arc.
 
double arcAngle
 Angle of the arc; it is positive, if the arc is on the right-hand side of the straight segment.
 

Detailed Description

Representation of an arc segment of a two dimensional polygon.

Remarks
Refer to the API_Polygon structure for more details.