Archicad 28 C++ API
|
Contains information about the current project. More...
#include <APIdefs_Environment.h>
Public Attributes | |
bool | untitled |
Indicates that the project file has not been saved yet. | |
bool | teamwork |
Signed into a team project or not. | |
short | userId |
team project member ID; if signed into a team project. | |
Int32 | workGroupMode |
team project member rights; if signed into a team project | |
IO::Location * | location |
Location of the non-teamwork project file. | |
IO::Location * | location_team |
the shared project file; if signed into a team project. | |
UInt64 | modiStamp |
Modification stamp of project. | |
GS::UniString * | projectPath |
optional; location of the project as string. | |
GS::UniString * | projectName |
optional; name of the project as Unicode string. | |
Contains information about the current project.
API_ProjectInfo::location_team |
the shared project file; if signed into a team project.
Destroys the project info (also cleans up)