Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PropertyObjectParams Struct Reference

Defines parameters for the property handler function. More...

#include <APIdefs_Callback.h>

Public Attributes

API_PropertyObjectCmdID cmd
 The identifier of the command the handler was called for. Its value can be APIPropObj_None, APIPropObj_AssignProperty, or APIPropObj_DisableProperty.
 
GS::uchar_t propertyName [API_UniLongNameLen]
 The Unicode name of the property library part.
 
char propertyUnID [128]
 The property library part's unique ID.
 

Detailed Description

Defines parameters for the property handler function.

Remarks
See the example for APIPropertyObjectCommandProc.