Archicad 28 C++ API
Loading...
Searching...
No Matches
API_PublishFormatData Struct Reference

Represents the data of a publisher format. More...

#include <APIdefs_Registration.h>

Public Attributes

GS::UniString mimeType
 MimeType of the new publish format. The MimeType has to be unique.
 
GS::UniString popUpText
 Popup text will be the name of the new publish format, on the publisher dialog.
 
GS::UniString fileExtText2D
 File extension in case of 2D save.
 
GS::UniString fileExtText3D
 File extension in case of 3D save.
 
GS::Array< API_WindowTypeIDwindowTypes
 Describes the new format in which windows is available.
 
bool singleFile
 In case of true, the new registered format gives the possibility to merge all content in one file (like PDF format).
 
GS::Array< API_WindowTypeIDwindowTypesInSingleFile
 Describes, the new format in which windows are available in single file mode. If singleFile bool is false, this array has to be empty.
 
short iconID
 The resource ID of the new publisher format’s icon.
 

Detailed Description

Represents the data of a publisher format.