Archicad 28 C++ API
Loading...
Searching...
No Matches
API_RefLevelsPrefs Struct Reference

The representation of the Reference Levels on the Preferences / Working Units Levels tab page. More...

#include <APIdefs_Environment.h>

Public Attributes

GS::UniString * level1UStr
 The name of the first reference level.
 
GS::UniString * level2UStr
 The name of the second reference level.
 
double level1val
 The value of the first reference level.
 
double level2val
 The value of the second reference level.
 

Detailed Description

The representation of the Reference Levels on the Preferences / Working Units Levels tab page.

Remarks
This structure is used by the ACAPI_ProjectSetting_GetPreferences function to get the settings of the Working Units Levels preferences page.