Archicad 28 C++ API
Loading...
Searching...
No Matches
API_RubberPolyCallbacks Struct Reference

Parameters of the polygon input operation. More...

#include <APIdefs_Interface.h>

Public Attributes

GSPtr * rubberLineInfoProc
 [in] Callback function for custom feedback drawing. See the RubberLineInfoProc.
 
GSPtr * get3DComponentProc
 [in] Callback function to query the 3D component. See the Get3DComponentProc.
 
GSPtr * addPolyNodeProc
 [in] Callback function for custom feedback editing polygons. See the AddPolyNodeProc.
 
GSPtr * delPolyNodeProc
 [in] Callback function for custom feedback editing polygons. See the DelPolyNodeProc.
 

Detailed Description

Parameters of the polygon input operation.

Remarks
For the utilization of API_RubberPolyCallbacks see the ACAPI_UserInput_GetPoly.