Archicad 28 C++ API
Loading...
Searching...
No Matches
API_SubSet Struct Reference

Represents a Subset in the Layout Book. More...

#include <APIdefs_Database.h>

Public Attributes

GS::uchar_t name [API_LongNameLen]
 Name of the subset.
 
bool doNotInclude
 Do not include this Subset in ID sequence.
 
bool customNumbering
 Custom ID or automatically generated.
 
bool continueNumbering
 Continue using ID assignment of upper levels.
 
bool useUpperPrefix
 Use prefix and IDs of upper levels.
 
bool addOwnPrefix
 Add own prefix for this Subset.
 
bool filler [3]
 Reserved for later use.
 
GS::uchar_t customNumber [API_LongNameLen]
 Custom number for the subset.
 
GS::uchar_t autoNumber [API_LongNameLen]
 Automatic numbering format for the subset.
 
API_NumberingStyle numberingStyle
 ID appearance style.
 
Int32 startAt
 Start numbering at.
 
GS::uchar_t ownPrefix [API_LongNameLen]
 Prefix for the subset.
 

Detailed Description

Represents a Subset in the Layout Book.

Remarks
You can get the default Subset settings via ACAPI_Navigator_GetSubSetDefault function. ACAPI_Navigator_CreateSubSet creates a Subset in the Layout Book.