Archicad 28 C++ API
|
Sun angle settings. More...
#include <APIdefs_Elements.h>
Public Attributes | |
double | sunAzimuth |
rotation angle of the Sun around the target | |
double | sunAltitude |
Sun's altitude. | |
API_SunAngleSettings_SunPositionOption | sunPosOpt |
this enumeration tells if the azimuth and altitude values have to be considered or the Sun position is given with a date (project location-dependent!) | |
unsigned short | year |
date's year. | |
unsigned short | month |
date's month | |
unsigned short | day |
date's day | |
unsigned short | hour |
date's hour | |
unsigned short | minute |
date's minute | |
unsigned short | second |
date's second | |
bool | summerTime |
this option controls daylight saving | |
bool | filler |
Reserved for later use. | |
Sun angle settings.