Archicad 27 C++ API
Loading...
Searching...
No Matches
API_Tranmat Struct Reference

A 3*4 transformation matrix. More...

#include <APIdefs_Base.h>

Public Attributes

double tmx [12]
 

Detailed Description

A 3*4 transformation matrix.

Remarks
This structure represents a standard 3*4 transformation matrix for linear transformations. The transformed coordinates are calculated using the below formula: x' = tmx[0] * x + tmx[1] * y + tmx[2] * z + tmx[3] y' = tmx[4] * x + tmx[5] * y + tmx[6] * z + tmx[7] z' = tmx[8] * x + tmx[9] * y + tmx[10] * z + tmx[11]