Archicad 28 C++ API
Loading...
Searching...
No Matches
API_UnitConversionData Struct Reference

Input and output struct for ACAPI_Conversion_GetConvertedUnitValue. More...

#include <APIdefs_Environment.h>

Public Attributes

double value
 [in] Contains the value to convert. It should be in m/m²/m³/radian.
 
API_UnitConversionPrefID unitConvPref
 [in] Specifies the Project Preference, which has to be used for conversion. For the supported values see API_UnitConversionPrefID.
 
GS::uchar_t convertedValue [64]
 [out] Contains the converted value, in the unit and rounding specified by the Project Preference.
 
GS::uchar_t extraAccuracy [4]
 [out] Contains the extra accuracy decimals, if any. It may be "1"–"99", "5", "25"/"5"/"75" or the empty string.
 
GS::uchar_t unit [64]
 [out] Contains the unit of the converted value.
 

Detailed Description

Input and output struct for ACAPI_Conversion_GetConvertedUnitValue.

Remarks
Angles and imperial measured values can have several units, thus in these cases the unit is left empty, and the unit(s) are concatenated to convertedValue.