Archicad 28 C++ API
|
The representation of the Preferences / Zones tab page. More...
#include <APIdefs_Environment.h>
Public Attributes | |
double | nichDepth |
The depth of the recesses to Zone. | |
double | nichSize |
The size of the recess to Zones. | |
unsigned char | nichCombineMode |
The relation between depth and size variable. It can be one of the following constants: APIRecess_And , APIRecess_Or . | |
bool | nichWindFlag |
Whether the recesses created by windows are included in the Zone size, depending on values of the nichDepth , nichSize , and the relation of those. | |
bool | nichDoorFlag |
Whether the recesses created by windows are included in the Zone size, depending on values of the nichDepth , nichSize , and the relation of those. | |
bool | nichDepthFlag |
Whether the minimal value for the depth of the wall recesses (nichDepth ) is taken notice of. | |
bool | nichSizeFlag |
Whether the minimal value for the size of the wall recesses (nichSize ) is taken notice of. | |
bool | subtrWallFlag |
Whether the areas of wall elements are subtracted from the Zone size. | |
bool | subtrColuFlag |
Whether the areas of columns elements are subtracted from the Zone size. | |
unsigned char | subtrWallPercent |
Percent of subtraction for the wall elements from the Zone sizes. | |
unsigned char | subtrColuPercent |
Percent of subtraction for the column elements from the Zone sizes. | |
double | subtrWallSize |
The minimal square meters for the wall elements placed inside a Zone area to subtract areas of walls from Zone sizes. | |
double | subtrColuSize |
The minimal square meters for the columns elements placed inside a Zone area to subtract areas of columns from Zone sizes. | |
unsigned char | nLowAreas |
Number of height limits for ceiling reduction. | |
unsigned char | roomRedPercents [4] |
The ratios for height limits (roomHeightLimits) to take into account for calculating Zone sizes. | |
double | roomHeightLimits [4] |
The height limits to take into account for calculating Zone sizes. | |
The representation of the Preferences / Zones tab page.