Archicad 28 C++ API
Loading...
Searching...
No Matches
APIOptional< T > Struct Template Reference

Represents an optional in the API layer. More...

#include <API_ValueWrappers.hpp>

Public Member Functions

template<typename K >
void operator= (K v)
 Sets a value to the optional.
 
void operator= (NullValueType nullOpt)
 Sets null value to the optional.
 

Public Attributes

bool hasValue
 True if the APIOptional has value.
 
value
 Value of the optional.
 

Detailed Description

template<typename T>
struct APIOptional< T >

Represents an optional in the API layer.

Since
Archicad 27

Member Function Documentation

◆ operator=() [1/2]

template<typename T >
template<typename K >
void APIOptional< T >::operator= ( v)
inline

Sets a value to the optional.

Parameters
vValue to set.

◆ operator=() [2/2]

template<typename T >
void APIOptional< T >::operator= ( NullValueType  nullOpt)
inline

Sets null value to the optional.

Parameters
nullOptNull value type to set.