Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalElemPartId Class Reference

Describes the guid, contour and edge/vertex id triplet that is used for creating the API_ExportIdMappingType. More...

#include <APIdefs_AnalyticalModel.h>

Public Member Functions

ULong GenerateHashValue () const
 Generates a hash value in order to use API_AnalyticalElemPartId type in GSRoot containers.
 
bool operator== (const API_AnalyticalElemPartId &right) const
 Comparison operator for API_AnalyticalElemPartId.
 

Public Attributes

API_Guid memberGuid
 This value represents the guid of the member.
 
UIndex contourIndex
 This value represents the index of the contour.
 
UIndex edgeOrVertexIndex
 This value represents the index of the edge or vertex.
 

Detailed Description

Describes the guid, contour and edge/vertex id triplet that is used for creating the API_ExportIdMappingType.

Since
Archicad 24

Member Function Documentation

◆ GenerateHashValue()

ULong API_AnalyticalElemPartId::GenerateHashValue ( ) const
inline

Generates a hash value in order to use API_AnalyticalElemPartId type in GSRoot containers.

Returns
A hash value.

◆ operator==()

bool API_AnalyticalElemPartId::operator== ( const API_AnalyticalElemPartId right) const
inline

Comparison operator for API_AnalyticalElemPartId.

Parameters
rightThe other API_AnalyticalElemPartId object.
Returns
True if the two objects are equal.