Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AttributeIndex Class Reference

Index reference to an attribute. More...

#include <APIdefs_AttributeIndex.hpp>

Public Member Functions

bool operator== (const API_AttributeIndex &rightOp) const
 Comparison operator.
 
bool operator!= (const API_AttributeIndex &rightOp) const
 Comparison operator.
 
Int32 ToInt32_Deprecated () const
 
ULong GenerateHashValue () const
 Generate a hash value that's why API_AttributeIndex can be used with GS::HashTable.
 
GSErrCode ReadAsInt32 (GS::IChannel &ic)
 Read the attribute index from the given channel.
 
GSErrCode WriteAsInt32 (GS::OChannel &oc) const
 Write the attribute index to the given channel.
 
GS::UniString ToUniString () const
 
bool IsPositive () const
 
bool IsNegative () const
 

Friends

API_AttributeIndex ACAPI_CreateAttributeIndex (Int32 index)
 A wrapper function to create an API_AttributeIndex from its GS equivalent.
 

Detailed Description

Index reference to an attribute.

Remarks
 In version 23, the short type attribute index references are replaced with this new type definition.

Member Function Documentation

◆ GenerateHashValue()

ULong API_AttributeIndex::GenerateHashValue ( ) const
inline

Generate a hash value that's why API_AttributeIndex can be used with GS::HashTable.

Returns
Generated hash value.

◆ IsNegative()

bool API_AttributeIndex::IsNegative ( ) const
inline
Returns
Returns true if the attribute index is less than zero.

◆ IsPositive()

bool API_AttributeIndex::IsPositive ( ) const
inline
Returns
Returns true if the attribute index is more than zero.

◆ operator!=()

bool API_AttributeIndex::operator!= ( const API_AttributeIndex rightOp) const
inline

Comparison operator.

Parameters
rightOpThe index to compare.
Returns
True if the given parameter is not equal to the index.

◆ operator==()

bool API_AttributeIndex::operator== ( const API_AttributeIndex rightOp) const
inline

Comparison operator.

Parameters
rightOpThe value to compare.
Returns
True if the given parameter is equal to the index.

◆ ReadAsInt32()

GSErrCode API_AttributeIndex::ReadAsInt32 ( GS::IChannel &  ic)
inline

Read the attribute index from the given channel.

Parameters
icInput channel.
Returns
Returns NoError if the reading was successful, otherwise with error.

◆ ToInt32_Deprecated()

Int32 API_AttributeIndex::ToInt32_Deprecated ( ) const
inline
Returns
Returns the attribute index as Int32

◆ ToUniString()

GS::UniString API_AttributeIndex::ToUniString ( ) const
inline
Returns
Returns the attribute index as GS::UniString.

◆ WriteAsInt32()

GSErrCode API_AttributeIndex::WriteAsInt32 ( GS::OChannel &  oc) const
inline

Write the attribute index to the given channel.

Parameters
ocOutput channel.
Returns
Returns NoError if the writing was successful, otherwise with error.

Friends And Related Symbol Documentation

◆ ACAPI_CreateAttributeIndex

API_AttributeIndex ACAPI_CreateAttributeIndex ( Int32  index)
friend

A wrapper function to create an API_AttributeIndex from its GS equivalent.

Since
Archicad 27
Parameters
index[in] The attribute index to convert.
Returns
The API equivalent.