Archicad 28 C++ API
Loading...
Searching...
No Matches
API_ElemPartId Struct Reference

Identify a part of an element. It's valid for PolyRoof and Morph only. More...

#include <APIdefs_Elements.h>

Public Member Functions

 API_ElemPartId ()
 Constructor which resets the data members.
 
bool operator== (const API_ElemPartId &right) const
 Comparison operator.
 
bool operator!= (const API_ElemPartId &right) const
 Comparison operator.
 
ULong GenerateHashValue () const
 Generates unique identifier.
 

Public Attributes

UInt32 main
 VertexId of the pivot polygon (relevant only for PolyRoof).
 
UInt32 sub
 Level of part (relevant only for PolyRoof).
 
Int32 floor
 Floor number (relevant only for Mesh).
 

Detailed Description

Identify a part of an element. It's valid for PolyRoof and Morph only.

Member Function Documentation

◆ GenerateHashValue()

ULong API_ElemPartId::GenerateHashValue ( ) const
inline

Generates unique identifier.

Returns
the unique value

◆ operator!=()

bool API_ElemPartId::operator!= ( const API_ElemPartId right) const
inline

Comparison operator.

Parameters
rightOther elempart to compare to.
Returns
True if it is not equal to right.

◆ operator==()

bool API_ElemPartId::operator== ( const API_ElemPartId right) const
inline

Comparison operator.

Parameters
rightOther elempart to compare to.
Returns
True if it is equal to right.