Archicad 28 C++ API
Loading...
Searching...
No Matches
API_InternalAnalyticalMemberPartId Class Reference

Describes a Structural Analytical Model Analytical Member part. More...

#include <APIdefs_AnalyticalElements.h>

Public Member Functions

bool operator== (const API_InternalAnalyticalMemberPartId &right) const
 Comparison operator for API_InternalAnalyticalMemberPartId.
 
ULong GenerateHashValue () const
 Generates a hash value in order to use API_InternalAnalyticalMemberPartId type in GSRoot containers.
 

Public Attributes

UIndex contourIdx
 This value represents the index of the contour.
 
UIndex edgeOrVertexIdx
 This value represents the index of the edge or vertex.
 
UIndex edgeFragmentIndex
 This value represents the index of the edge fragment.
 

Detailed Description

Describes a Structural Analytical Model Analytical Member part.

Since
Archicad 25

Member Function Documentation

◆ GenerateHashValue()

ULong API_InternalAnalyticalMemberPartId::GenerateHashValue ( ) const
inline

Generates a hash value in order to use API_InternalAnalyticalMemberPartId type in GSRoot containers.

Returns
A hash value.

◆ operator==()

bool API_InternalAnalyticalMemberPartId::operator== ( const API_InternalAnalyticalMemberPartId right) const
inline

Comparison operator for API_InternalAnalyticalMemberPartId.

Parameters
rightThe other API_InternalAnalyticalMemberPartId object.
Returns
True if the two objects are equal.