Archicad 28 C++ API
|
This is the complete list of members for IFCAPI::v1::PropertyBuilder, including all inherited members.
CreateAttribute(const GS::UniString &name, const std::optional< GS::UniString > &value) const | IFCAPI::v1::PropertyBuilder | |
CreateClassification(const GS::UniString &name, const std::optional< GS::UniString > &source, const std::optional< GS::UniString > &edition, const std::optional< GS::UniString > &editionDate, const std::optional< GS::UniString > &description, const std::optional< GS::UniString > &location) const | IFCAPI::v1::PropertyBuilder | |
CreateClassificationReference(const std::optional< GS::UniString > &location, const std::optional< GS::UniString > &identification, const std::optional< GS::UniString > &name, const IFCAPI::Classification &referencedSource, const GS::UniString &relAssociatesClassificationName) const | IFCAPI::v1::PropertyBuilder | |
CreateEmptyValue() const | IFCAPI::v1::PropertyBuilder | |
CreatePropertyBoundedValue(const GS::UniString &propertySetName, const GS::UniString &name, const IFCAPI::Value &lowerBoundValue, const IFCAPI::Value &upperBoundValue, const IFCAPI::Value &setPointValue) const | IFCAPI::v1::PropertyBuilder | |
CreatePropertyEnumeratedValue(const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &enumerationReference, const std::vector< IFCAPI::Value > &enumeratedValues) const | IFCAPI::v1::PropertyBuilder | |
CreatePropertyListValue(const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &listValues) const | IFCAPI::v1::PropertyBuilder | |
CreatePropertySingleValue(const GS::UniString &propertySetName, const GS::UniString &name, const IFCAPI::Value &value) const | IFCAPI::v1::PropertyBuilder | |
CreatePropertyTableValue(const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &definingValues, const std::vector< IFCAPI::Value > &definedValues) const | IFCAPI::v1::PropertyBuilder | |
CreateValue(const IFCAPI::IFCType &valueType, const IFCAPI::AnyValue &anyValue) const | IFCAPI::v1::PropertyBuilder | |
GetPropertyBuilder | IFCAPI::v1::PropertyBuilder | friend |
GetToken() const | ACAPI::v1::Object | |
mImpl | ACAPI::v1::Object | protected |
Object(std::shared_ptr< Impl::ObjectImpl > impl) | ACAPI::v1::Object | |
~Object() | ACAPI::v1::Object | protected |
~PropertyBuilder() (defined in IFCAPI::v1::PropertyBuilder) | IFCAPI::v1::PropertyBuilder |