Archicad 28 C++ API
Loading...
Searching...
No Matches
IFCAPI::v1::PropertyBuilder Class Referencefinal

To create IFC attribute, property or classification reference. More...

#include <IFCPropertyBuilder.hpp>

Inheritance diagram for IFCAPI::v1::PropertyBuilder:
ACAPI::v1::Object

Public Member Functions

ACAPI::Result< ValueCreateValue (const IFCAPI::IFCType &valueType, const IFCAPI::AnyValue &anyValue) const
 Create an IFC value.
 
Value CreateEmptyValue () const
 Create an empty IFC value.
 
ACAPI::Result< IFCAPI::AttributeCreateAttribute (const GS::UniString &name, const std::optional< GS::UniString > &value) const
 Create an IFC attribute from scratch.
 
ACAPI::Result< IFCAPI::PropertyCreatePropertySingleValue (const GS::UniString &propertySetName, const GS::UniString &name, const IFCAPI::Value &value) const
 Create an IFC property single value.
 
ACAPI::Result< IFCAPI::PropertyCreatePropertyTableValue (const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &definingValues, const std::vector< IFCAPI::Value > &definedValues) const
 Create an IFC property table value.
 
ACAPI::Result< IFCAPI::PropertyCreatePropertyListValue (const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &listValues) const
 Create an IFC property list value.
 
ACAPI::Result< IFCAPI::PropertyCreatePropertyBoundedValue (const GS::UniString &propertySetName, const GS::UniString &name, const IFCAPI::Value &lowerBoundValue, const IFCAPI::Value &upperBoundValue, const IFCAPI::Value &setPointValue) const
 Create an IFC property bounded value.
 
ACAPI::Result< IFCAPI::PropertyCreatePropertyEnumeratedValue (const GS::UniString &propertySetName, const GS::UniString &name, const std::vector< IFCAPI::Value > &enumerationReference, const std::vector< IFCAPI::Value > &enumeratedValues) const
 Create an IFC property enumerated value.
 
ACAPI::Result< IFCAPI::ClassificationCreateClassification (const GS::UniString &name, const std::optional< GS::UniString > &source, const std::optional< GS::UniString > &edition, const std::optional< GS::UniString > &editionDate, const std::optional< GS::UniString > &description, const std::optional< GS::UniString > &location) const
 Create an IFC classification from scratch.
 
ACAPI::Result< ClassificationReferenceCreateClassificationReference (const std::optional< GS::UniString > &location, const std::optional< GS::UniString > &identification, const std::optional< GS::UniString > &name, const IFCAPI::Classification &referencedSource, const GS::UniString &relAssociatesClassificationName) const
 Create an IFC classification reference from scratch.
 
- Public Member Functions inherited from ACAPI::v1::Object
 Object (std::shared_ptr< Impl::ObjectImpl > impl)
 Constructs a new object.
 
const API_TokenGetToken () const
 Get the token for this object.
 

Friends

PropertyBuilder GetPropertyBuilder ()
 Get PropertyBuilder to create IFC attribute, property or classification reference.
 

Additional Inherited Members

- Protected Member Functions inherited from ACAPI::v1::Object
 ~Object ()
 Default destructor.
 
- Protected Attributes inherited from ACAPI::v1::Object
std::shared_ptr< Impl::ObjectImplmImpl
 Impl object given by constructor.
 

Detailed Description

To create IFC attribute, property or classification reference.

Since
Archicad 28
Remarks
See IFCHook_Test.cpp for a complete example.

Friends And Related Symbol Documentation

◆ GetPropertyBuilder

PropertyBuilder GetPropertyBuilder ( )
friend

Get PropertyBuilder to create IFC attribute, property or classification reference.

Since
Archicad 28
Returns
The PropertyBuilder
Remarks
See IFCHook_Test.cpp for a complete example.