Archicad 28 C++ API
Loading...
Searching...
No Matches
Tracking::Tracker::HintGuard Class Reference

Helper guard class to specify a hint what to do when the editing of a field needs to be ended and possibly the reason for ending it. More...

#include <Tracker.hpp>

Public Member Functions

 HintGuard (Tracker &trackerToGuard, Hint newHint)
 Starts the scope of the hint.
 
 ~HintGuard ()
 Finishes the scope of the hint.
 

Detailed Description

Helper guard class to specify a hint what to do when the editing of a field needs to be ended and possibly the reason for ending it.