Archicad 28 C++ API
Loading...
Searching...
No Matches
Publisher

Functions for integrating into the publisher or registering new supported file types. More...

Typedefs

typedef GSErrCode SaveProc(API_SaveMethod method, const char *path, API_UserData *userData, GS::UniString *reportStr)
 Callback function to save the document in the newly registered publish format.
 
typedef GSErrCode SaveOptionProc(API_SaveMethod method, API_UserData *userData)
 Callback function to set different options for the newly registered format.
 
typedef GSErrCode TranslatorGetterProc(GS::Array< API_TranslatorNameConfig > &arr)
 Callback function to receive the translators for the new registered publish forma.
 
typedef GSErrCode DefaultTranslatorGetterProc(API_TranslatorNameConfig &def)
 
typedef GSErrCode InfoGetterProc(const API_UserData *const userData, GS::UniString &info, bool general)
 

Detailed Description

Functions for integrating into the publisher or registering new supported file types.

Typedef Documentation

◆ DefaultTranslatorGetterProc

typedef GSErrCode DefaultTranslatorGetterProc(API_TranslatorNameConfig &def)

Callback function to receive the default translator for the new registered publish format.

Parameters
def[out] The output parameter of this function. This configuration will be set to hold the default translator of the format.
Returns
  • NoError - The function has been completed with success.

◆ InfoGetterProc

typedef GSErrCode InfoGetterProc(const API_UserData *const userData, GS::UniString &info, bool general)

Callback function to receive a string providing additional information about a publisher format or it's current configuration.

Parameters
info[out] The info string that can be displayed by the Publisher.
general[in] Indicates that the info string should have contents for a Publisher Folder item has the same format items, but with different info
Returns
  • NoError - The function has completed with success.

◆ SaveOptionProc

typedef GSErrCode SaveOptionProc(API_SaveMethod method, API_UserData *userData)

Callback function to set different options for the newly registered format.

Parameters
method[in] Any of ``` Save2DProc, SaveSectionProc, Save3DProc, SaveRenderingProc, SaveTextProc, SaveReportProc, SaveDrawProc, SaveLayoutProc, SaveMovie3DProc, SaveMovieRenderingProc, SaveDetailDrawingProc, SaveIESProc, SaveDocumentFrom3DProc ```
userData[in] The userData contains the save options given by the Add-On.
Returns
  • NoError - The function has been completed with success.

◆ SaveProc

typedef GSErrCode SaveProc(API_SaveMethod method, const char *path, API_UserData *userData, GS::UniString *reportStr)

Callback function to save the document in the newly registered publish format.

Parameters
method[in] Any of ``` Save2DProc, SaveSectionProc, Save3DProc, SaveRenderingProc, SaveTextProc, SaveReportProc, SaveDrawProc, SaveLayoutProc, SaveMovie3DProc, SaveMovieRenderingProc, SaveDetailDrawingProc, SaveIESProc, SaveDocumentFrom3DProc ```
path[in] The path where to save the published file.
userData[in] The userData contains the save options given by the Add-On.
reportStr[in] The error message if the publishing failed.
Returns
  • NoError - The function has been completed with success.

◆ TranslatorGetterProc

typedef GSErrCode TranslatorGetterProc(GS::Array< API_TranslatorNameConfig > &arr)

Callback function to receive the translators for the new registered publish forma.

Parameters
arr[out] The array which will be filled with translator configurations.
Returns
  • NoError - The function has been completed with success.