Archicad 28 C++ API
|
Custom data record attached to element sets. More...
#include <APIdefs_Elements.h>
Public Attributes | |
short | dataVersion |
the version of the user data | |
unsigned short | platformSign |
the platform the data was created on; defines the byte ordering (can be GS::Win_Platform_Sign, GS::Mac_Platform_Sign or GS::Mactel_Platform_Sign | |
GSFlags | flags |
Special flags | APIUserDataFlag_Pickup | copy userdata into default at element parameter transfer | | APIUserDataFlag_SkipRecalcAndDraw | ACAPI_Element_SetUserData skips recalc and redraw (input only control flag) | | APIUserDataFlag_FillWith | inject userdata into element from default |. | |
GSHandle | dataHdl |
handle containing the user data (arbitrary size) | |
Custom data record attached to element sets.
Value | Meaning |
---|---|
APIUserDataFlag_Copy | Copy the user data into the copied element also |
APIUserDataFlag_Merge | Merge user data with the element |
APIUserDataFlag_FillWith | Inject user data into the element instance from the element default |
APIUserDataFlag_Pickup | Copy user data into the element default at parameter transfer |
APIUserDataFlag_SkipRecalcAndDraw | ACAPI_Element_SetUserData skips recalculation and redraw (input only control flag). |