Archicad 28 C++ API
|
Common header for the 3D components. More...
#include <APIdefs_3D.h>
Public Attributes | |
API_3DTypeID | typeID |
Identifies the type of the component. | |
Int32 | index |
The index field gives the current database index of the given component. Note that this number is not constant for a particular element through the whole life of the project element index. | |
Int32 | elemIndex |
Gives the internal element index plus one for a body; output only parameter for API_BodyType. It can be used to get the (u,v) texture coordinates with ACAPI_ModelAccess_GetTextureCoord. | |
Int32 | bodyIndex |
Gives the internal body index plus one for a body; output only parameter for API_BodyType. It can be used to get the (u,v) texture coordinates with ACAPI_ModelAccess_GetTextureCoord. | |
Common header for the 3D components.