Archicad 28 C++ API
Loading...
Searching...
No Matches
API_3DCutPlanesInfo Struct Reference

Data of the "3D Cutting Planes..." dialog. More...

#include <APIdefs_Environment.h>

Public Attributes

bool isCutPlanes
 3D cutaway on
 
bool useCustom
 Custom edges and surfaces of elements cut in 3D Sections.
 
short customPen
 Custom pen.
 
API_AttributeIndex customMater
 Custom material.
 
short nShapes
 Number of the shapes.
 
API_3DCutShapeType ** shapes
 Shapes of the cutting planes.
 

Detailed Description

Data of the "3D Cutting Planes..." dialog.

Remarks
The API_3DCutPlanesInfo structure is used by the ACAPI_View_Get3DCuttingPlanes and the ACAPI_View_Change3DCuttingPlanes environment functions. Don't forget to dispose of the shapes handle when it is not needed anymore.