Archicad 28 C++ API
|
Describes the Analytical Model Visiblity Settings. More...
#include <APIdefs_AnalyticalModel.h>
Public Attributes | |
API_AM_VisibilityMode | visibilityMode = API_AM_VisibilityMode::AnalyticalModelOnly |
Describes the Analytical Model Visiblity Mode. | |
bool | isAnalyticalModelVisible = false |
Describes whether the Analytical Model is visible. | |
bool | areMembersTransparent = false |
Describes whether the Members of the Analytical Model are transparent. | |
bool | areSymbolsTransparent = false |
Describes whether the Symbols of the Analytical Model are transparent. | |
bool | areNodesVisible = false |
Describes whether the Nodes of the Analytical Model are visible. | |
bool | areReleasesVisible = false |
Describes whether the Releases of the Analytical Model are visible. | |
bool | areCrossSectionsVisible = false |
Describes whether the Cross Sections of the Analytical Model are visible. | |
bool | areCoordinationProfilesVisible = false |
Describes whether the Coordination Profiles of the Analytical Model are visible. | |
bool | areLocalCoordSystemsVisible = false |
Describes whether the Local Coordination Systems of the Analytical Model are visible. | |
API_LoadVisibilityMode | loadVisibilityMode |
Visiblity mode of the Loads in the Analytical Model. | |
Describes the Analytical Model Visiblity Settings.