Archicad 27 C++ API
Loading...
Searching...
No Matches
API_AddOnInfo Struct Reference

Textual description of the add-on. More...

#include <APIdefs_Registration.h>

Public Attributes

GS::UniString name
 The name of the add-on, in Unicode.
 
GS::UniString description
 The description of the functionality of the add-on, in Unicode.
 
API_SSALevel requiredSSALevel
 If the add-on requires an SSA subscription in order to function, set this member to the required minimum subscription level (see.
 

Detailed Description

Textual description of the add-on.

Since
Archicad 26
Remarks
This is a member of the API_EnvirParams structure used in the CheckEnvironment function. The description appears in the Add-On Manager dialog of Archicad. Both strings should come from a localizable resource. When set, the requiredSSALevel field instructs Archicad to handle this add-on as dependent on Software Service Agreements. Note, however, that any restrictions in functionality (e.g., disabling commands) should be implemented separately in the add-on. From API 21 the name and description fields are in Unicode; you shouldn't call BNZeroMemory or memset.