Archicad 27 C++ API
Loading...
Searching...
No Matches
API_EnvirParams Struct Reference

Describes the different parameters of the running environment. More...

#include <APIdefs_Registration.h>

Public Attributes

API_ServerApplicationInfo serverInfo
 Read-only information about the server application the add-on is running under.
 
API_AddOnInfo addOnInfo
 Textual description of the add-on; the add-on should fill this in.
 

Detailed Description

Describes the different parameters of the running environment.

Remarks
This is the parameter of the CheckEnvironment function. The serverInfo member is read-only, while the addOnInfo part should be filled by the add-on by return. From API 21 you shouldn't call BNZeroMemory or memset on this structure.