Archicad 27 C++ API
Loading...
Searching...
No Matches
API_ServerApplicationInfo Struct Reference

Describes the current server application the add-on is running under. More...

#include <APIdefs_Registration.h>

Public Attributes

API_ApplicationTypeID serverApplication
 The server application (Archicad or the 3D Engine).
 
UInt16 mainVersion
 The main version of the server application.
 
Int16 releaseVersion
 The sub- (release) version of the server application.
 
bool runningInBackground
 The server application was started in background mode.
 
Int32 buildNum
 The build number of the server application (not for the 3D Engine)
 
GS::UniString language
 The language of the server application as a C string (not for the 3D Engine). For example it contains "@c INT" for the international version, "@c JPN" for the Japanese version.
 
GS::UniString partnerID
 When Archicad runs on an SSA license this field contains the internal identifier of the reseller.
 

Detailed Description

Describes the current server application the add-on is running under.

Since
Archicad 26
Remarks
This is a read-only member of the API_EnvirParams structure, passed as a parameter to the CheckEnvironment function. It can be also obtained with the ACAPI_AddOnIdentification_Application function. From API 21 you shouldn't call BNZeroMemory or memset on this structure.