Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalLoadCombination Struct Reference

Describes a Structural Analytical Load Combination. More...

#include <APIdefs_AnalyticalModel.h>

Public Attributes

GS::UniString name
 Name of the load combination.
 
GS::UniString description
 Description of the load combination.
 
API_AnalyticalLoadCombinationCategory category
 The category of the load combination.
 
GS::Optional< API_AnalyticalLoadCombinationNationalStandard > nationalStandard
 The National code application of the load combination.
 
GS::Optional< API_LoadCombinationType > type
 The type of the load combination.
 
GS::Array< API_AnalyticalLoadFactorloadFactors
 An array which contains the load cases (and the adherent coeffients) of the load combinations.
 
API_Guid guid
 A unique identifier of the represented load combination.
 

Detailed Description

Describes a Structural Analytical Load Combination.

Since
Archicad 25