Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalPointLoad_Settings Struct Reference

Describes the Structural Analytical Model Analytical Point Load settings. More...

#include <APIdefs_AnalyticalElements.h>

Public Attributes

API_Guid loadCaseId
 The guid of the connected Load Case.
 
API_AnalyticalLoad_LoadForceType loadForceType
 The force type of the Analytical Point Load. The point force can be defined in three main directions (global or local coordinate system). A node of the structure may be subject to a moment load. The load is defined by the direction and size of the moment.
 
API_AnalyticalCoordSysDirection coordinateSystemType
 The coordinate system type of the Analytical Point Load.
 
double xValue
 The force/moment value in X direction of the Analytical Point Load.
 
double yValue
 The force/moment value in Y direction of the Analytical Point Load.
 
double zValue
 The force/moment value in Z direction of the Analytical Point Load.
 

Detailed Description

Describes the Structural Analytical Model Analytical Point Load settings.

Since
Archicad 25