Archicad 28 C++ API
Loading...
Searching...
No Matches
API_AnalyticalReleaseDescription Struct Reference

Contains the Structural Analytical Model Analytical Member Release values. More...

#include <APIdefs_AnalyticalModel.h>

Public Attributes

API_AnalyticalRigidityType ux
 Translation type in X direction.
 
double stiffnessX
 Translation value in X direction in case of Custom type.
 
API_AnalyticalRigidityType uy
 Translation type in Y direction.
 
double stiffnessY
 Translation value in Y direction in case of Custom type.
 
API_AnalyticalRigidityType uz
 Translation type in Z direction.
 
double stiffnessZ
 Translation value in Z direction in case of Custom type.
 
API_AnalyticalRigidityType fix
 Rotation type in X direction.
 
double stiffnessFix
 Rotation value in X direction in case of Custom type.
 
API_AnalyticalRigidityType fiy
 Rotation type in Y direction.
 
double stiffnessFiy
 Rotation value in Y direction in case of Custom type.
 
API_AnalyticalRigidityType fiz
 Rotation type in Z direction.
 
double stiffnessFiz
 Rotation value in Z direction in case of Custom type.
 
API_AnalyticalMemberPartRef amPartRef
 The Structural Analytical Member part referenced.
 

Detailed Description

Contains the Structural Analytical Model Analytical Member Release values.

Since
Archicad 24